99 7.3L Throwing Codes, How Bad is it? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-12-2012, 11:09 AM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2009
Posts: 481
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 5 reviews
99 7.3L Throwing Codes, How Bad is it?

Hey Guys,

I just took our 99 7.3L Work Truck with 120k miles in for a regular service and inspection. It had a check engine light on so they ran a diagnostic and it pulled the following codes;

P1391
P1393
P1396

How screwed am? I don't really want to take it in to ford to fix if at all possible I would like to do the work myself but I don't know how to further diagnose the codes.

Any help would be great, thanks guys.

John
colin@greenoil is offline  
post #2 of 5 Old 04-12-2012, 01:30 PM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 6,204
Thanks: 7
Thanked 233 Times in 224 Posts
Mentioned: 6 Post(s)
Quoted: 75 Post(s)
Feedback Score: 3 reviews
All Glow Plug related, shouldn't be too serious, go through the steps in this link and you'll know more....

Troubleshooting GPR & GP's

Your codes come back in this range;

P1391-GP Circuit Low Input Bank No. 1 (RH)

P1392-GP Circuit High Input Bank No. 1 (RH)

P1393-GP Circuit Low Input Bank No. 2 (LH)

P1394-GP Circuit High Input Bank No. 2 (LH)

P1395-GP Monitor Fault Bank No. 1

P1396-GP Monitor Fault No. 2
NoRalPh is offline  
post #3 of 5 Old 04-12-2012, 01:40 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,072
Thanks: 79
Thanked 473 Times in 457 Posts
Mentioned: 2 Post(s)
Quoted: 233 Post(s)
Garage
Feedback Score: 0 reviews
If this is a California Truck, it probably has a GPM (Glow Plug Module), not just a relay. Mine is and mine does. I had to replace it in September '10.



I got mine through RockAuto.com. Obviously, there are other places to get one.


Owner | Operator: Darryl
My Truck Garage: Ol' Guy
Tow Toy Garage : Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #4 of 5 Old 04-12-2012, 01:46 PM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2009
Posts: 481
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 5 reviews
Well that doesn't sound all too bad, where is it located in the engine compartment?

Thanks,

John
colin@greenoil is offline  
post #5 of 5 Old 04-12-2012, 02:37 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,072
Thanks: 79
Thanked 473 Times in 457 Posts
Mentioned: 2 Post(s)
Quoted: 233 Post(s)
Garage
Feedback Score: 0 reviews
Mine is on the valley side of the passenger side valve cover, if I remember right, it's closer to the front of the engine.


Owner | Operator: Darryl
My Truck Garage: Ol' Guy
Tow Toy Garage : Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome