25c UVCH plugs fixed, still no start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-05-2012, 03:21 PM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Location: Palm Beach
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
25c UVCH plugs fixed, still no start

Hey guys, this is my 4th 7.3 PSD, I have done injectors and stuff before, so I know my way around.

Just picked up clean 2000 with 330k. Ran great on 500mi trip, 22mpg @70mph on highway. Started losing power last night around town, I parked it, and did quarter fix under both valve covers this afternoon. One plug was about 3mm out along entire length, other one was 2mm out on one corner

Tried to start, turns over strong, tries to fire but nothing. Rpm needle moves, so its not CPS. Batteries are @12v and good

I pulled fuel filter, it was dirty. Will replace in the morning. While filter was out I turned the key to Acc position and filmed fuel flow, does this look normal, it was just barely gurgling?

http://static.photobucket.com/player.../VIDEO0010.mp4

Oil looks reasonably clean, and is at the lower Add mark. I am gonna try and add a quart?

Does this sound like LPOP went dead?

Thanks for any suggestions. Diablo reports no trouble codes.

Last edited by man-o-war; 04-05-2012 at 03:35 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-06-2012, 11:32 AM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Location: Palm Beach
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Added 5gal of fuel (on top of just under 1/4 tank) and it fired right up. I guess fuel pickup is broken in the tank, time to do the Hutch/Harpoon

Happy Strokin'
Reply With Quote Quick reply to this message
  #3  
Old 04-06-2012, 12:23 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Dover
Posts: 1,618
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
That is an interesting video! Lol

Yeah, guess it was pulling a little air! Haha
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:31 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors