Loss of power - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-05-2012, 01:34 PM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loss of power

2000 7.3 Excursion. 287 thousand miles. Sat for a year. Changed oil and fuel filter. Put in fuel stabilizer with 5 fresh gallons of fuel. Now shows just under 1/2 tank. Starts fine. No CEL. No smoke. Idles fine. When I drive it won't go over 1600 RPM's. Very slowly will increase speed. Too slow to make it worth talking about. At idle in park RPM"s will increase as normal up to red line. I'm very ignorant to all the different sensors, etc. If it is a known problem please indicate the name of the sensor or valve if that is causing the problem. One fellow said it was the Accelerator Pedal and Sensor Assembly. Another said if that was the problem I would not be able to accelerate at all. With that I don't feel comfortable investing $317.00 for that part. Thanks for any help or advise.

Last edited by xgrizx; 04-06-2012 at 06:15 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:10 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors