IDM failures......... - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 03-26-2012, 07:06 AM Thread Starter
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,604
Thanks: 9
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
IDM failures.........

Hello All. I know it's been a while... I'm having an issue and need some help.

My rig (in sig) is having a problem. 280K miles and the idm decided to go south. Got another Replaced with another IDM and within 10 miles it goes south too. I'm figuring there is a short somewhere killing the IDM's but I haven't the slightest idea as to where to start. My brother is the one doing the work at the moment because I'm hardly ever home. Any good tips on where to start would be much appreciated or if anyone has run across this issue before and can shed some light would be greatly appreciated as well.

A little bit of back story too just incase. For the last few years the truck would be running fine and then all of a sudden buck like the cps was failing. At first this was very few and far between and only seemed to happen in the rain. The CPS was never an issue though. Checked all harness connections and found no signs of water intrusion, short in plugs, or overheating etc... The last few months it would get worse bucking more randomly. Then one day my brother was driving it and it died. After a few hours of troubleshooting narrowed it down to the IDM. Replaced IDM and within the first 10 miles of driving (brother driving it again) it dies. Same symptoms as the IDM failing.

Also another symptom. When it fails to start something is drawing a charge. Batteries will die overnight with full charge. I know it is shorting somewhere just can't seem to find it.

Rig: 2000 F-350 7.3 6-speed 280K miles. I thought I had it in sig but dont....
Current mods if it matters, itp regulated return, dac3 ecm, turbonetics ball bearing turbo, afe stage II. Everything else is back to stock.

Thanks in Advance!

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook

Last edited by MrJohnWayne; 03-26-2012 at 07:21 AM.
MrJohnWayne is offline  
post #2 of 6 Old 03-26-2012, 07:17 AM Thread Starter
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,604
Thanks: 9
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
Also I can't remember all the codes but non were important except for one. I don't remember the actual code but it was something along the lines of no communication between idm and ecm... I'll dig it up and post too.

thanks!

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook
MrJohnWayne is offline  
post #3 of 6 Old 03-27-2012, 06:11 AM Thread Starter
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,604
Thanks: 9
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
bump..............

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook
MrJohnWayne is offline  
post #4 of 6 Old 04-09-2012, 09:01 PM
Member
 
smokinstrokin99's Avatar
 
Join Date: Oct 2011
Location: aberdeen, washington
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
try checking out your injector wire harnedd under each valve cover..buddys 00' had that same problem but would only run for 10 seconds and go to hell. swapped out idms and it ended up being that harness on the passenger side



smokinstrokin99 is offline  
post #5 of 6 Old 04-09-2012, 09:20 PM
Mob boss

 
Jarrod B's Avatar
 
Join Date: Jul 2008
Location: Austin Texas
Posts: 26,951
Thanks: 25
Thanked 27 Times in 25 Posts
Mentioned: 2 Post(s)
Quoted: 148 Post(s)
Feedback Score: 1 reviews
under valve cover harness is one. glow plug relays work? cruise control recall done?

2006 Ford F250 CCSB FX4 6.0

Sold
1997 F350 CCLB 2WD 7.3
1999 F350 CCLB 4WD 7.3
2003 F350 CCLB FX4 6.0





LSP Chapter Director

LSP Group Threads
http://www.powerstroke.org/forum/lon...-powerstrokes/
Jarrod B is offline  
post #6 of 6 Old 04-10-2012, 03:47 AM
Compression Ignition Addict
 
Turbostang500's Avatar
 
Join Date: Oct 2011
Location: Dover
Posts: 1,634
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
cruise control switch could cause the battery drain.

If the windshield starts leaking, doesn't it leak right on top of the IDM?

Lee

2000 F250 PSD SCSB 4X4 418k miles straight pipe gauges 2" leveling kit 315/75r16's
6637 with custom intake pipe. TS Performance 6 position chip!
[/URL]


Please don't confuse my attitude with my personality.. my personality is who I am,my attitude depends on who you are...
Turbostang500 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome