Turbo squeak please help - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-22-2012, 06:09 PM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thumbs down Turbo squeak please help

Hi all, I started experiencing a squeak from what I thought was the turbo along with a vibration and loss of boost so I replaced the turbo with a larger Garrett, pedestal and did an ebpv delete. After a short test drive all seemed to be fixed until a further distance proved other wise. Now, the boost was still low to start due to the waste gate needing adjusted but the vibration and squeak soon returned. Is the turbo not getting oil? There is no leaks and good oil pressure and a brand new pedestal! I am stumped and can't afford to keep guessing. Please help!!
Turbostroke02 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome