random dieing issue - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-06-2012, 04:38 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Posts: 101
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
random dieing issue

My truck has started randomly dieing. Sometimes come to a stop an itwill start idleing rough then die. Starts back up fine sometimes will die again. I can Rev it. Up after it dies an it'll be fine. An sometimes during normal driving petal becomes UN responsive. Hpop has 4999 psi at idle. An climbs in rpms. I'm thinking cps.any ideas
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-06-2012, 07:08 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2012
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by svt28640 View Post
My truck has started randomly dieing. Sometimes come to a stop an itwill start idleing rough then die. Starts back up fine sometimes will die again. I can Rev it. Up after it dies an it'll be fine. An sometimes during normal driving petal becomes UN responsive. Hpop has 4999 psi at idle. An climbs in rpms. I'm thinking cps.any ideas
Your HPOP should NOT read 4999psi @ idle.

It should read somewhere between 500-1000psi when cranking depending on HPOP condition. (it takes minimum500psi to pop the injectors, and ive seen as high as 1000psi cranking)

You need to check the ICP sensor/plug/harness in my opinion
Reply With Quote Quick reply to this message
  #3  
Old 03-08-2012, 05:38 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Posts: 101
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Would the icp sensor being bad make it have less power?
Reply With Quote Quick reply to this message
  #4  
Old 03-08-2012, 06:24 AM
Serving Our Country!


 

Join Date: Apr 2008
Location: Everett WA
Posts: 3,623
Thanks: 0
Thanked 10 Times in 8 Posts
Feedback Score: 0 reviews
Send a message via AIM to buckels Send a message via MSN to buckels Send a message via Yahoo to buckels
Quote:
Originally Posted by svt28640 View Post
Would the icp sensor being bad make it have less power?
It can. I broke my ICP sensor when working on my truck and I lost power and it acted just like you are saying. I dont know what my pressure was cause I didnt have a gauge for that but I would be willing to bet that is your problem.

Last edited by buckels; 03-09-2012 at 07:59 AM.
Reply With Quote Quick reply to this message
  #5  
Old 03-18-2012, 04:24 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Posts: 101
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok i hooked my scan tool to my tuck tonight an happened to check the codes.. Does not have a check engine light but has 11 codes. I know the po238(boost sensor a to hi) was from over boost( fixed that with regulator) an the p01249 (wastegate control valve performance) is from the turbo being non wastgated an the plug/vaccum hoses being gone. an the p0541(intake air heater) its deleted) But still has p0232 fuel pump secondary circuit high, p1209, P1210, P1211 INJ control pressure system, P0471 exhaust pressure sensor circuit performance,P0475 exhaust pressure control valve fault, P0340 CPS circuit, and P0743 TCC system electrical fault. .. Happened to have the data up on my scan tool when the pedal went dead an idle dropped an inj control psi jumped to 20750, The truck has seemed to been weaker then normal lately but never get drove much. My mods are in the Signature .

Last edited by svt28640; 03-18-2012 at 04:27 PM.
Reply With Quote Quick reply to this message
  #6  
Old 04-04-2012, 03:23 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Posts: 101
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok guys new info I changed my icp sensor an it did nothing, I changed the scan tool setting from kpa to psi an it now reads 725 psi at idle an about 1100 psi at 2000 rpms. It now has like a dead miss/lope shakes. And only has p1210 an p1211 codes now. But if you hook the scan tool up to the truck while running an try clearing the codes it kills me
Reply With Quote Quick reply to this message
  #7  
Old 04-04-2012, 03:35 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Posts: 101
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
also now if its ran a while. when u cut it off an try to start it back it will idle way low like 3-500 an pedal want do nothing. cut it off an try it again it will be fine sometimes have to cut it off 2 or 3 times
Reply With Quote Quick reply to this message
  #8  
Old 04-07-2012, 03:27 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Posts: 101
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The Icp is new. Ipr is replaced with known good one
Its still throwing 1210 an 1211 codes. Does this mean hpop?
Reply With Quote Quick reply to this message
  #9  
Old 04-07-2012, 10:03 AM
Oregon Redneck



 

Join Date: Mar 2012
Location: PT Mugu, CA
Posts: 334
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
My pickup is doing the same thing.
Reply With Quote Quick reply to this message
  #10  
Old 04-15-2012, 09:17 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Posts: 101
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have changed the icp, ipr, idm, an my oil pump has 2600psi at wot loaded not optimum but shouldn't be low enough to Cause problem. But it still throwing icp codes 1210 an 1211 an after driving when you turn the truck off an try to start back it does the pedal unresponsive an crappy idle. Well just for hell of it I unplugged icp an it starts back fine everysingle time.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:08 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors