2 qts every 5000 miles since day 1? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-05-2012, 08:24 PM Thread Starter
Powerstroke.org Rookie
 
mnichols2010's Avatar
 
Join Date: Jul 2011
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2 qts every 5000 miles since day 1?

My old ford has burned 2 quarts of oil every 5000 miles since day 1 it doesn't bother me just wondering if they all do this or if something maybe out of wack


Sent from my Autoguide iPad app

2000 7.3 4x4 ranch hand everywhere, 18000 lbs warn winch, pisa lights, 5 inch turbo back, ts 6 pos custom tunes by Gearhead Automotive, 6637 diy 07, harley lights
mnichols2010 is offline  
post #2 of 2 Old 03-06-2012, 06:59 AM
Powerstroke.org Fanatic
 
Join Date: Jan 2012
Posts: 99
Thanks: 3
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My early99 has 591,000mi on body, 425,000mi on motor, and it does not consume any oil, leak any fluids, smoke, knock, or have excessive blow-by...
the trav is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome