Wont start after GPR relay drained batteries - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-05-2012, 04:54 PM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry Wont start after GPR relay drained batteries

I have an 02 7.3L. I replaced the glow plug relay only to find it was the wrong relay. The relay stayed on the whole time it was installed and drained the batteries. While I was trying to start the truck and troubleshooting why it wouldn't start it drained the batteries. I took the wrong relay out and put the old one back in (it started before as long as it was plugged in and warm). After installing the old relay it wont start. Its nice and warm and the batteries are 100% charged. It cranks and cranks and cranks. No smoke. I've checked every fuse and relay...about three times each. Can't find a bad fuse. I get a code of P0380- glow plug circuit. I'm lost and ready to put a rag in the tank and light it on fire.
utahboy is offline  
Sponsored Links

gpr wont start

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome