1996 7.3 fires off, wont run - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2012, 01:59 PM
Member
 

Join Date: Jul 2009
Posts: 79
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1996 7.3 fires off, wont run

Apologies , I need to post this in the correct forum.

I'm helping my cousin get his 1996 F350 7.3 auto back up and running. It will fire off but only run for one or two seconds then it shuts off.

Changed the fuel filters, blew out the return line, replaced the fuel preheater. There was a lot of sludge when these parts were disassembled and cleaned. Truck started and ran fine after the previous maintenance for only about 20 miles then resumed the original symptoms.

Fuel seems to flow real well through the disconnected return however we havnt checked pressure at the shrader valve. Thinking about replacing the mechanical fuel pump and R&R the valve that switches between the fuel tanks.

Suggestions appreciated.

Last edited by motorhead440; 02-26-2012 at 02:05 PM. Reason: wrong forum
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors