revving high ??? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-21-2012, 04:19 PM Thread Starter
Member
 
Adub90's Avatar
 
Join Date: Feb 2008
Location: Midland texas
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
revving high ???

Im having some issues with my truck revving high, I normally run my truck on cruise at 65 and my rpms are around 1700 to 1800, but for some reason now it is running at 2000 for no apparent reason and im not sure what is causing this, any help is greeatly appriciated.

early 99 7.3
Tymar
zoodad
4" straight pipe
banks big head
banks trans command
mag hytech tanny pan
315 nitto terra grapplers
rear end replacement
banks egt and boost gauge
DP-Tuner, no start, 80hp econo, 120 race
DIY boost fooler
ccv


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Adub90 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-21-2012, 04:25 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,558
Thanks: 88
Thanked 517 Times in 501 Posts
Mentioned: 5 Post(s)
Quoted: 288 Post(s)
Garage
Feedback Score: 0 reviews
Just throwing stuff out that comes to mind.

Anything change recently - Tire size, any programming?

Could the TC be slipping? Notice any issues getting to speed?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Owner | Operator: Darryl
My Truck Garage:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Tow Toy Garage :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #3 of 4 Old 02-21-2012, 07:49 PM Thread Starter
Member
 
Adub90's Avatar
 
Join Date: Feb 2008
Location: Midland texas
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
nothing has changed as far as programming and tire size, i was noticing that my powersteering pump has been whining a lot more lately and im not sure if thats putting an extra load on the motor, im not sure if the TC is slipping, how would I be able to tell?

early 99 7.3
Tymar
zoodad
4" straight pipe
banks big head
banks trans command
mag hytech tanny pan
315 nitto terra grapplers
rear end replacement
banks egt and boost gauge
DP-Tuner, no start, 80hp econo, 120 race
DIY boost fooler
ccv


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Adub90 is offline  
post #4 of 4 Old 02-22-2012, 07:07 PM Thread Starter
Member
 
Adub90's Avatar
 
Join Date: Feb 2008
Location: Midland texas
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Does anyone got something for me ??

early 99 7.3
Tymar
zoodad
4" straight pipe
banks big head
banks trans command
mag hytech tanny pan
315 nitto terra grapplers
rear end replacement
banks egt and boost gauge
DP-Tuner, no start, 80hp econo, 120 race
DIY boost fooler
ccv


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Adub90 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome