2000 PSD P1316 Code and check engine light - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-07-2012, 10:29 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2011
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Question 2000 PSD P1316 Code and check engine light

i just put full force diesel stage 2 160cc injectors. garrett gtp38r turbo, and a dp tuner, and a regulated return fuel system in my 2000f550 PSD... i am getting a p1316 IDM codes detected code... and my check engine light comes on and off while driving usually comes ona round 2500rpms. but once they go down it turns off... My mechanic double checked everything and couldnt find anything loose of broken.. Could it be the injectors? or could we just have missed something..

The truck drives perfect.. doesnt seem to have any misfires or any issues... but when the engine light comes on it seems to lose power and runs rough... im still learning about diesels so i figured i would ask about it on here... any ideas? that i can do or have him do? i know he is doing everything he can to diagnose this but i wanted to do whatever i can to help him out...
BadAssJK is offline  
post #2 of 4 Old 02-07-2012, 11:32 AM
MIG
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the same issue.The 1316 IDM code i got tierd of trying to fix it myself and ended up having to drop it in the shop.They looked it over and found that the injector connectors were not making a good connection.Btw new uvch was installed by me.He got rid of most of the 1316 related codes except two.The injector solenoids are the culprit i need to replace #2 and #3 and it will solve the problem.These were rebult injectors i put in by Diesel Care come to find out they dont replace the solenoids.Funny thing was i didnt have that code until i replaced my injectors too.The misfire could be that the connector is not making a good contact
MIG is offline  
post #3 of 4 Old 02-07-2012, 12:14 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2011
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I will look into the uvch harness and the connectors. Hopefully it's not more than just a bad connection after I just spent all that money on the new injectors. Turbo. Etc... Not much $$$ left to work with here. It's jut wierd that it only happens half the time.


Sent from my Autoguide iPhone app
BadAssJK is offline  
post #4 of 4 Old 12-03-2012, 02:13 AM
Compression Ignition Addict
 
probuilder's Avatar
 
Join Date: Feb 2010
Location: Ladora, IA
Posts: 157
Thanks: 3
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Do a Buzz test on the injectors, that should tell you if you have a bad solenoid(s) on your re-manned injectors.
I have the same problem, but my SES light only comes on when you step on the accelerator, then when you let off it will go out. Truck runs perfect all the time. You may want to read this article. Ford 7.3L Power Stroke

2011 F350 XLT, CC LB, 4x4, SRW, Powerstroke 6.7, Mini Maxx, Factory Remote Start added, Productivity screen added, All White.
probuilder is offline  
Reply

Tags
7.3 injectors , idm f550 7.3 powerstroke , p1316

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome