weird power loss!!! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 02-03-2012, 04:34 PM Thread Starter
Powerstroke.org Rookie
 
strokin it 99's Avatar
 
Join Date: Feb 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
weird power loss!!!

ok right to the point. i lose power when i go over 3/4 throttle. i build more boost but feels like it flat lines. i thought at first it was blowing power through the converter. i recently blew up my motor and just put in another motor and while i was in there i put a brand new converter in it, still same problem.

i can put pedal to the metal and it pulls hard but at higher rpms (25psi boost) it feels like its not going any faster. i can let off to 3/4 throttle and it pulls tramendously harder??? i dont understand, im building more boost at wot and its going slower.

i've checked icp, second turbo, disconnected waste gate, pulled air filter (put right back in) changed fuel filter, did oil change, even put in another ecm. I havent been able to find anyone else online with these symptoms. any help would be appreciated. thanks

- early 99 f-350 with 170k
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

- afe cold air intake
- 06 interior swap
- 5" exhaust no cat or muff
- 06 front suspension, rize ind 4link, oru hydraulic steering assist, 4:56 gears, cross over steering, dual bilsteins all the way around, ladder bars
- 38x15.50-20 (wallet wont allow 40x24s.....yet
strokin it 99 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 02-03-2012, 04:59 PM
Powerstroke.org Rookie
 
Join Date: Jan 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
is it a 6.0 hook a computer run a injector test and heui pump. test drive down the road and watch the air fuel flow ratios make sure your icp is at 3500psi to 4000 when u get into it. make sure fuel pressure is in range, and deff check the cam sensor make for its reading at high rpm cause that will make u loose throttle response.
justinwdiesel is offline  
post #3 of 7 Old 02-03-2012, 07:57 PM
Compression Ignition Addict
 
1snakedoc's Avatar
 
Join Date: May 2010
Location: AL
Posts: 385
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
could it be you have to much air not enough fuel of oil psi? what has the motor had done to it?

Matt PAA #117 99.5 F-250 XLT CC SWB 4x4 4R100 Warn M12000 GPR-LED. Foil Delete. 6637. 0.50. AC. Isspro Dual Pyrometer. AeroForce. FRx. HPx. DIY SS Fuel Lines. 03 HeadLights. 4" SS Exhaust. 6.0L Trans Cooler. BTS Tunes. Custom Lighted Tuner. IH Up Pipes. EPBV Delete. AIH delete. Isspro Boost Trans. Van Turbo WW2.
1snakedoc is offline  
post #4 of 7 Old 02-04-2012, 05:33 AM
Member
 
Join Date: Dec 2011
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
25 psi of boost. do you have a boost fooler hooked up. might be defueling. I'm not positive but I think the motor defuels itself at around 22 psi.
mostlystock is offline  
post #5 of 7 Old 02-04-2012, 09:22 AM
Banned
 
Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Quote:
Originally Posted by mostlystock View Post
25 psi of boost. do you have a boost fooler hooked up. might be defueling. I'm not positive but I think the motor defuels itself at around 22 psi.
^That's my guess.. but if it's not that, I would look into finding a scanner and checking the health of the HPOP.
ToMang07 is offline  
post #6 of 7 Old 02-04-2012, 12:53 PM
Compression Ignition Addict
 
desertdeer's Avatar
 
Join Date: Jun 2011
Location: cedar city utah
Posts: 227
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
are your injectors stock?
desertdeer is offline  
post #7 of 7 Old 12-14-2012, 06:05 PM
Powerstroke.org Rookie
 
Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the same problem but when mine happens it blows so much smoke it's UN real
01ty is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome