runs real rough - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-15-2005, 08:41 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
runs real rough

We have a 2000 f350 7.3 liter diesel. son was driving a while ago and said he heard a clunk noise and truck now runs really rough. Towed it to mechanic and so far he said the engine is probably gone. Any advise would be greatly appreciated. Over 100 thousand so I figure warranty is out.
mad in north pole is offline  
post #2 of 4 Old 10-24-2005, 02:24 PM
Member
 
Join Date: Sep 2005
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Did you check the turbo? Maybe it went. If you get the egt to high you can melt them. Normally when a motor goes they bang like crazy or don't run period. Remove the boot from the turbo and make sure that it turns freely and has no excesive play! Good luck. P.S Start the truck and make it spins properly with the boot off so you can see it!! Maybe a broken injector!?

Last edited by lancer; 10-24-2005 at 02:51 PM.
lancer is offline  
post #3 of 4 Old 01-13-2006, 06:13 PM
Powerstroke.org Rookie
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by mad in north pole
We have a 2000 f350 7.3 liter diesel. son was driving a while ago and said he heard a clunk noise and truck now runs really rough. Towed it to mechanic and so far he said the engine is probably gone. Any advise would be greatly appreciated. Over 100 thousand so I figure warranty is out.

PULL THE VALVE COVERS AND CHECK FOR BENT PUSH RODS. IT IS A COMMON PROBLEM WITH THE 7.3 ENGINE WHEN THEY ARE OVER REVED. SIMPLE FIX IT REALLY DOESNT TAKE TOO LONG TO DO IF THATS YOUR PROBLEM. YES THEY STILL DO RUN WITH BENT PUSH-RODS JUST RUNS LIKE CRAP. PUTTING GAS IN TANK WILL OFTEN BEND PUSH-RODS AS WELL.
MTNMAN is offline  
post #4 of 4 Old 01-13-2006, 06:23 PM
Banned
 
Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 5 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i agree, pull the valve covers, but the big thing is that if it is running rough, you may have had an injector go down and you may, or may not have bent push rods. if you get both valve covers off and have no bent push rods, start the motor, and disconnect each injector, at the injector, one by one, reconnecting them if the motor runs WORSE when its disconnected. if you disconnect one, and the motor DOES NOT change the way it is running, that injector is bad.........if you need more info or have any questions, let me know.
mschn99 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome