Wastegate and or Turbo Surge? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-25-2011, 06:58 PM Thread Starter
Member
 
Join Date: Aug 2010
Location: Zanesville, Ohio
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Wastegate and or Turbo Surge?

I am having a few problems. I just installed a BTS trans and a TS chip. I do not seem to be getting the boost that I should. Im only getting like 14 psi at wot. The truck has sat for a few months while I waited on parts, i dont know if that would do anything or not. I know that when I bought it a little over a year ago it would make 23psi with an Edge evo on it. For the last 6 months I drove it pretty easy because I knew the trans was going out so im not sure how long ive been having these issues. Also on the interstate today at wot I was getting a ch ch ch noise in rapid succession. I just found an up pipe leak today on the passenger side that I will fix tomorrow hopefully. Any ideas?
Lando302 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-25-2011, 07:15 PM
Serving Our Country!
 
JSchuricht's Avatar
 
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,975
Thanks: 0
Thanked 27 Times in 26 Posts
Mentioned: 1 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
I would start off by doing a pressurizing the intake and doing a leak check, likely a boot is loose or bad. Could also be a clogged intake, bad turbo or a fueling issue but start off small and fix the leak you already know about.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JSchuricht is offline  
post #3 of 3 Old 11-25-2011, 07:18 PM Thread Starter
Member
 
Join Date: Aug 2010
Location: Zanesville, Ohio
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yea my plan is to fix the leak first and see what happens. Just hoping that its not turbo related. I just spent over 5k in trans chip and cooler, im all tapped out at the moment lol.
Lando302 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome