Power steering pump acting up. - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-20-2011, 05:36 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Power steering pump acting up.

My power steering pump doesn't work for a few seconds every once in a while when you're shifting from reverse to drive or the opposite. Otherwise it works fine. If you're in drive it works great and has no problems. It doesn't do it every time either.

When I back out of the drive sometimes it's fine. Sometimes it is really stiff and takes a second for the power steering pump to kick in with any assist.

My concern is I just bought a Boss 8'2" poly V-plow which is not going to be easy on the power steering pump. If it's acting up now, I can only imagine how it'd die when I'm out plowing this year.


Any thoughts? I'm wondering if my pump is just on the way out or if the fluid needs to be flushed. I bought the truck used so I don't know if the steering fluid had ever been changed.



2000 F250 7.3L Powerstroke -4x4

Automatic Transmission
Mile Marker selectable hubs
4" stainless exhaust with 3.5 down pipe
Truetrac limited slip in the rear
Boss 8'2" Poly VXT Plow
DP-Tuner F5 - Stock, 80hp Econo, 100hp performance, 60hp tow
hypocrisyB is offline  
post #2 of 3 Old 11-21-2011, 01:44 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I'm going to flush the system and replace the power steering pump this Thursday. Anyone have any suggestions as to anything else I should be looking at before doing this?



2000 F250 7.3L Powerstroke -4x4

Automatic Transmission
Mile Marker selectable hubs
4" stainless exhaust with 3.5 down pipe
Truetrac limited slip in the rear
Boss 8'2" Poly VXT Plow
DP-Tuner F5 - Stock, 80hp Econo, 100hp performance, 60hp tow
hypocrisyB is offline  
post #3 of 3 Old 11-24-2011, 10:53 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I flushed the power steering system and replaced the pump. Still no change here. Anyone have any ideas that they can throw at me?



2000 F250 7.3L Powerstroke -4x4

Automatic Transmission
Mile Marker selectable hubs
4" stainless exhaust with 3.5 down pipe
Truetrac limited slip in the rear
Boss 8'2" Poly VXT Plow
DP-Tuner F5 - Stock, 80hp Econo, 100hp performance, 60hp tow
hypocrisyB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome