High Pressure Oil Pump on 2001 7.3 - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-09-2011, 08:05 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2008
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
High Pressure Oil Pump on 2001 7.3

2001 7.3 with 103,000. Over the past year all the O rings in the High Pressure Oil Lines have leaked and been replaced. At 95,000 the HPOP started leaking and was replaced with a new Ford. That lasted 8,000 miles and now that new pump is leaking. Under Ford warranty. What is going on?? The Diesel Mechanic says this is not normal. Never had a chip. Any ideas??
Dale Ballard is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome