Before I replace the EBP sensor.... - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-15-2011, 07:28 PM Thread Starter
Compression Ignition Addict
Join Date: Mar 2011
Posts: 1,015
Thanks: 0
Thanked 9 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
Feedback Score: 0 reviews
Before I replace the EBP sensor....

I have a "service engine soon" light on. An ODBII scanner turns up the error code related to "exhaust back pressure too high". I cleaned out the EBP sensor (it was packed full of carbon), and rotor-rooted the carbon out of the EBP tube and fitting, but still get the same error. Is there anything else to check before replacing the EBP sensor? Best price I've seen is $72 for new OEM.
ttyR2 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome