runs bad - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-09-2011, 08:30 AM Thread Starter Rookie
Join Date: Feb 2011
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
runs bad

i have 99 f-350 psd this is what i have had done so far 1)1 injector 8 glow plugs at dealer $1200 ran fine for a while then it started skipping again so took it to another who said i needed injectors so 8 injectors a $2700 later im still running bad so now he says i need engine wiring harness and idm so $400 later im running alright 2weeks later im skipping again one injector bad replaced it running good again 1week later skipping again but only while you driving it but last night sitting at a redlight it dropped a cylinder any ideas anybody on what i should or can do
cocoa2852 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome