several issue just started today - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-29-2011, 01:53 PM
Powerstroke.org Fanatic
 

Join Date: May 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
several issue just started today

So today I was cruising down the highway and the truck starts knocking, I pull over it does it for a few more seconds then quits. I head off down and about 10 miles later it starts again, this time its blowing white smoke. It does it for another minute or so then stops.

I called Swamps (I've got their injectors) and he says first thing I should do it check the fuel pressure. So I head to the parts store to pick up a few things . In the parking lot my truck decides to puke all the coolant out (it looks like from the cap). I fill it up and start the truck and its running fine again, I then drive back to my office and it started throwing up again today. Oh and when i drove away it started blowing white smoke again....

Do we think head gasket or a strange coincedince?

Other than that im stumped, the top of the motor doesnt have any water or oil on it. Im going to try and fill the coolant resevoir with water and see if I can see oil in the mixture but I could defintely use some help!

Thanks guys!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-29-2011, 01:59 PM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 30,948
Thanks: 106
Thanked 88 Times in 82 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Head gaskets or EGR cooler
Reply With Quote Quick reply to this message
  #3  
Old 06-29-2011, 02:03 PM
Banned
 

Join Date: Jul 2008
Location: Would rather be in WY
Posts: 3,782
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dave, most 7.3s I've seen don't have EGR coolers.
Reply With Quote Quick reply to this message
  #4  
Old 06-29-2011, 02:37 PM
Powerstroke.org Fanatic
 

Join Date: May 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
uhoh.....so were thinking head gasket?

When I drove back from the parts place it only blew white smoke for about 2-3 minutes then it ran smooth as silk.
Reply With Quote Quick reply to this message
  #5  
Old 06-30-2011, 08:42 AM
Powerstroke.org Fanatic
 

Join Date: May 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
again, last night jumped in the truck to get home from work. I filled the resevour all the way up right before I left and got home and it was still about half way full of coolant. Then the truck puked up some more and the rest went somewhere besides the resevour.

Also, it ran terrible and blew white smoke for about a minute then ran totally fine.

I checked the oil for water and vice versa and dont see any mixing of the two. Im stumped, I would assume that if it was the head gasket I would have some mixing. Also, the truck doesnt run hot at all.

Lastly, I have the CCV routed at the rear and Im getting much more smoke than normal.
Reply With Quote Quick reply to this message
  #6  
Old 06-30-2011, 09:18 AM
Powerstroke.org Fanatic
 

Join Date: May 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anyone have to replacer an injector cup? Same symptoms as Im seeing. Just not sure if there is a way to visually inspect.
Reply With Quote Quick reply to this message
  #7  
Old 07-03-2011, 04:56 PM
Johnny Law Brown

 

Join Date: Sep 2008
Location: Tipton, IN
Posts: 366
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
sounds like an injector cup
Reply With Quote Quick reply to this message
  #8  
Old 07-03-2011, 07:49 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Inglis, Florida
Posts: 709
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How long ago did you put injectors in? If recently maybe they didn't see right or weren't torqued enough and injector and injector cup(s) backed out causing you to get combustion in coolant system causing coolant to blow out? Just a thought. Or the cup(s) could be cracked.
Reply With Quote Quick reply to this message
  #9  
Old 07-05-2011, 12:51 PM
Powerstroke.org Fanatic
 

Join Date: May 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The injectors were put in by the previous owner, he stated that they have been in for around 3500 miles.

I went ahead and purchased the injector cups and will hopefully get them put in this weekend.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:41 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors