low boost w/ chip and intake - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-08-2011, 06:10 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
low boost w/ chip and intake

hi guys brand new on here and want to run a couple questions by people in the know. First will discribe what i'm working with: 2000 F250 7.3 160k miles, TS 6 position chip, AFE Stage 2 intake with ProGaurd, Edge CTS. About to get 5in turbo back MBRP exhaust with muffler delete.
That out of the way...when in stock position boost is reading max 10psi WOT. Wastegate duty cycle on idle reads 98.8% and lowest it gets is 68% WOT.
When in 50HP position constantly reads 98.8% wastegate, max again 10psi
When in 140HP same deal but wastegate does fall to 68% like stock.
What im asking is what could be going on with this. Could turbo be shot? Ive sprayed soapy water on uptake boots and no bubbles any other way to check? Ive heard donuts could be bad but havent checked.

Last edited by schnabelj; 05-08-2011 at 06:13 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-14-2011, 09:15 AM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump come on need some help here
Reply With Quote Quick reply to this message
  #3  
Old 05-14-2011, 09:33 AM
Banned
 

Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Sounds like a Boost leak to me. Wouldn't hurt to check the turbo wheel, too. (Pull the intake tube off it and check fins)

Theres a thread on here somewhere describing how to test the system, let me see if I can find it...

Reply With Quote Quick reply to this message
  #4  
Old 05-14-2011, 09:59 AM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Check your turbo wheel definitely, my bud n i just found one that looked like it got chopped up, that motor cant be happy, anyway your uppipes if they are leaking will have left plenty of soot on the firewall, if you see just a little its not likely..
Reply With Quote Quick reply to this message
  #5  
Old 05-14-2011, 10:01 AM
Banned
 

Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Did Boost leak test!!!!
Reply With Quote Quick reply to this message
  #6  
Old 05-24-2011, 09:41 AM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thank you all for the replies. I am going to be ordering my 5" exhaust this weekend and when i pull everything out for it ill check out the turbo. thanks again
Reply With Quote Quick reply to this message
  #7  
Old 05-24-2011, 09:48 AM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thank you all for the replies. I am going to be ordering my 5" exhaust this weekend and when i pull everything out for it ill check out the turbo. thanks again
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors