HELP Please, Not running good - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-05-2011, 06:46 PM Thread Starter
Emergency Services
Join Date: Dec 2006
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP Please, Not running good

I have a 2000 7.3 f250 and its not running good at all. first over the winter i noticed white smoke when startup and driving down the road, this has still continued, now as of a week ago it has started loosing power after bout 5min drive. it starts fine, runs ok but with white smoke until about 5 mins into my drive, it bogs down with no power and barely wnats to move, i then pull over, shut it off, and restart to have power back for maybe 2 minutes and repeat til i get home. it has code p1211. i have replaced fuel pump, fuel filter, and cleaned screens in sending unit bc it acted as it wasnt geting enough fuel. But still no success. Any ideas? this is my daily driver and i desperatly need help! Thank You in advance!

2002 Ford Excursion
7.3L Turbo Diesel

K&N Intake
F550 rear Springs
Muffler delete

Get - It - Done Landscaping and Home Improvement
Smithsburg, Md

strokeit is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome