Engine kicks and bucks in the rain, WTF? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-25-2011, 12:21 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: NW IN
Posts: 604
Thanks: 3
Thanked 26 Times in 19 Posts
Feedback Score: 0 reviews
Exclamation Engine kicks and bucks in the rain, WTF?

I got a problem that only happens on a rainy day. (every day this last 2 weeks) The engine kickes and bucks violently. It's like an intermittant miss, something electronic, but it shakes the whole truck, hard. Mechanic says a new computer (It shows "internal fault") The check engine light comes on, but resets if I turn the truck off. I am confused as hell. It only does this during wet weather... you really depend on a vehicle in bad weather. If there is anyone with any ideas... If the weather is nice, she runs like a striped ape . This rain crap is getting old, and it bucks so hard I'm afraid I'm gonna break something. HELP!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-25-2011, 05:13 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: NW IN
Posts: 604
Thanks: 3
Thanked 26 Times in 19 Posts
Feedback Score: 0 reviews
Help....
Reply With Quote Quick reply to this message
  #3  
Old 04-26-2011, 06:26 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,830
Thanks: 1
Thanked 80 Times in 75 Posts
Feedback Score: 3 reviews
Some people who've had this problem have found it's no as much to do with the water, as it does with the wipers being On, see if it still does it if you turn them Off.

Stumbles when it rains??
Reply With Quote Quick reply to this message
  #4  
Old 04-26-2011, 06:56 AM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Dickinson, TX
Posts: 3,956
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Send a message via Yahoo to drstephennix
If it isnt the wipers, you could always be sucking up a bunch of water through your zoodad mod. I never had a problem with mine, but it could be. May place a screeen over it or something of that nature.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:37 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors