Couple of stupid questions???? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-08-2011, 07:31 AM
Compression Ignition Addict
 

Join Date: Nov 2006
Posts: 194
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Couple of stupid questions????

Just bought a 99 F-250 with a 127-k miles, 7.3L Powerstroke, automatic tranny. Original ol' mans type truck with ZERO mods....

Truck goes down the road great, but noticed a slight miss at idle, has no blow by until I remove the breather lid then there is a light stream of blow by from the oil cap and zero from the dip stick tube.

I know it needs an oil change and would not hurt to chnage the fuel filter and air filter too. Anything else to check or do I need to run te buzz/cont. test as well?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-08-2011, 08:05 AM
The Tamed Racing Driver
 

Join Date: Oct 2009
Location: Home-Taneytown, Maryland; School- Lima, Ohio
Posts: 3,229
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
If you think it has a miss at idle then I would do a buzz test and a cylinder contribution test. Highly recomend fluid changes. You never know what the PO (previous owner) thought was acceptable.
Reply With Quote Quick reply to this message
  #3  
Old 04-08-2011, 09:56 AM
Compression Ignition Addict
 

Join Date: Nov 2006
Posts: 194
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
By the looks of it the owner just put diesel in it and drove it. It only has a 127-k miles but looks like 300-k...... I run a autocheck and carfax and it shows to be a 1-owner truck with actual miles so I took a chance as cheap as it was.

It might not be a an actual miss just not as smooth as some that I have had. It could very well be just changing all of the filters and fluids and running some fuel treatment in it.

Will run a buzz/cont test Monday after I have it serviced and see what it shows.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors