Engine Dies... Won't restart. Input Please! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-26-2011, 12:51 PM
Banned
 

Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Exclamation Engine Dies... Won't restart. Input Please!

Take 2:

Driving home @50mph, engine warm and everything working fine, the engine cut out like there was no fuel, and would not restart.

No fuses blew.

WTS light comes on like normal, but does NOT turn off.


I do not believe it is GP, GPR, or PCM related.

The mechanic put a cheap (NAPA) fuel bowl heater in, it started, ran for 30 min and died again, and would not start, same problems.

I am putting in a new CPS (Grey, From NAPA) tomorrow morning, as well as removing the PHP chip for further diagnostics.

Any other ideas of what to check???

The only other things I can think of is ICP sensor or IPR.

I would really apreciate some help, folks, Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-26-2011, 01:10 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my understading is the ICP sensor won't cause shutdowns, just rough idle. try checking the HPOP resevoir.
Reply With Quote Quick reply to this message
  #3  
Old 03-26-2011, 01:24 PM
Banned
 

Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Quote:
Originally Posted by sldghamr View Post
my understading is the ICP sensor won't cause shutdowns, just rough idle. try checking the HPOP resevoir.
Thats just looking for low oil level, right?
Reply With Quote Quick reply to this message
  #4  
Old 03-26-2011, 01:28 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have had same problem...truck (2006 F350 6.0) will just quit...has done this 3 times
have gone through 3 IPR's in 7 months and I think its bad again....truck quit on me lastnight. No lights or errors on programmer.
if its bad again I think I am going to relocate it. Anyone have any ideas?
Reply With Quote Quick reply to this message
  #5  
Old 03-26-2011, 02:49 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Richardson
Posts: 985
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Black&Gold Send a message via Skype™ to Black&Gold
just went through the same exact deal, ended up replacing ICP... that helped. but after i replaced the IPR purrrrrr baby purrrrr! I think it was bad for a while cause my truck even starts faster now and man the throttle response is NICE! I started by replacing the CPS, still no start, So i got on here did some research, and unplugged the ICP, wala! STARTED! got a new ICP plugged er up and it started up again. then started to run rough then died. threw a bunch of codes and all pointed to the IPR. bit the Huge Bullet and bought a new one. and I am now roalin' coal
Reply With Quote Quick reply to this message
  #6  
Old 03-26-2011, 03:23 PM
Banned
 

Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
B&G or anyone else ever try to rebuild the IPR?
7.3L Powerstroke IPR Valve Reseal Kit
http://www.accuratediesel.com/shop/167.html
http://www.fleetsource.com/Fuel_Injection_s/113.htm

Last edited by ToMang07; 03-26-2011 at 03:36 PM.
Reply With Quote Quick reply to this message
  #7  
Old 03-27-2011, 06:34 AM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I tried unplugging ICP, still no start....will plan on replacing ICP and IPR....
and who knows.......something has to be causing this...cant keep replacing IPR's.
Reply With Quote Quick reply to this message
  #8  
Old 03-27-2011, 07:21 AM
Banned
 

Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Quote:
Originally Posted by MJ01 View Post
I tried unplugging ICP, still no start....will plan on replacing ICP and IPR....
and who knows.......something has to be causing this...cant keep replacing IPR's.
I haven't tried mine yet... I plan to tomorrow morning. I went over today and took the chip out. CPS cost only $25 at NAPA. I'm prolly gonna try that tomorrow, too.
Reply With Quote Quick reply to this message
  #9  
Old 03-27-2011, 07:38 AM
jcs jcs is offline
Premium Member
 

Join Date: Apr 2007
Location: groton,Ma
Posts: 200
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by MJ01 View Post
I have had same problem...truck (2006 F350 6.0) will just quit...has done this 3 times
have gone through 3 IPR's in 7 months and I think its bad again....truck quit on me lastnight. No lights or errors on programmer.
if its bad again I think I am going to relocate it. Anyone have any ideas?
you probably have a different problem going on than the o.p. you have the 6.0 not the 7.3 but you probably have a bad sct fitting at the hpop
Reply With Quote Quick reply to this message
  #10  
Old 03-27-2011, 07:41 AM
jcs jcs is offline
Premium Member
 

Join Date: Apr 2007
Location: groton,Ma
Posts: 200
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
to the o.p. try taking a look at the wiring harness where it comes over the valve cover on the drivers side i had a similar problem where the wires chaffed on the valve cover and would stall and not restart
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:16 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors