99 7.3 rough to start and no power - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-22-2011, 04:18 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2008
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99 7.3 rough to start and no power

i have a decently modded 99 7.3 this problem occurred then fixed itself and is now haunting me again..... it turns over free no play in the arura but once it fires it sits there and idols a little rough but when i give it gas it seems like its running on 4 cyl. and i have been having problems with the HPOP if i let it sit i have to take out the sensor and add oil... what yall think it is i have very limited time SOMEONE HELP PLEASEEEE
rollincoal7.3 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome