99 7.3 injector problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-22-2011, 09:23 AM
Powerstroke.org Rookie
 

Join Date: Sep 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99 7.3 injector problem

Hello. Ok I have a 99 f350 itís got about 160,000 on it. The problem started about 2 years ago now. A friend had borrowed the truck one night then I get a call saying it broke down its blowing white smoke and has a loud knock in the engine. It turned out to be a bad injector one of the injectors was over fueling so I put a new injector in. about two weeks latter I was driving and same thing happened another injector failed the same way. so I replaced that one and about two weeks after I replaced that one another one went this time the injector tip broke off and fell into the motor lucky only damaging the piston. so I pulled the motor with a friend and replaced the piston and put 8 new injectors in the truck ran great for about 6 months then started to idle rough not really to noticeable but enough for me to tell. Brought it to my friends shop and did a buzz test and every thing else and came up with pcm-idm communication error I think it was code 1668. well being stupid I drove it for a little longer planning on bringing it to the ford dealer but just putting it off as the truck was only having a slight rough idle. Well yep another injector went and this was one of the 8 that I had replaced so I replaced it and brought to the ford dealer last month and they told me they could not get any codes from the truck because I had the batteries disconnected for about 3 or 4 weeks before it got there. They told me to drive for a day or two and come back. Well I only mad it about 8 miles from the dealer and another injector failed. I have pulled the idm out and opened it up to see if it had water damage and it looks fine also this truck has had 3 idmís replaced in it over the years. Iím thinking itís an electrical problem and has been looking into purchasing a breakout box to start trouble shouting any suggestions or help with this problem would be great thank you KyleÖ
Also here is a video of my truck I took last month when it broke again. This is the same way it has failed every time
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-22-2011, 07:22 PM
Powerstroke.org Rookie
 

Join Date: Feb 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
do you use Fuel Additives?
Reply With Quote Quick reply to this message
  #3  
Old 02-22-2011, 07:28 PM
Compression Ignition Addict
 

Join Date: Mar 2010
Location: zumbrota, mn
Posts: 607
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
thats painful to watch..... it is weird that you have had so many injector failures.
Reply With Quote Quick reply to this message
  #4  
Old 02-24-2011, 04:09 AM
Powerstroke.org Rookie
 

Join Date: Sep 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did use fuel additives after i replaced all the injectors. (power service product BIO KLEEN because the truck had sat for so long and a fuel system lubricant, i dont remember the product name).
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors