very rough idle and little to no power, have list of fault codes - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-21-2011, 09:55 AM
Powerstroke.org Rookie
 

Join Date: Feb 2011
Location: Caledon Ontario
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
very rough idle and little to no power, have list of fault codes

This is my first time posting, I am also fairly new to the 7.3

The truck is stock except for a straight pipe which I installed at the end of last week. I noticed after the install while warming up and the truck was on high idle, the idle wasn't always smooth. Yesterday while driving the truck close to home the check angine light came on the truck lost a lof of power. The truck idles very rough and has a hard time accelerating. I borrowed a code reader from a buddy and came up with seven fault codes.

P1280 continuous injection control pressure sensor low

P1670 continuous electronic feedback signal not detected

P0603 continuous power train module keep alive memory error

P1210 continuous injector controll pressure above expected level

P1316 Continuous injector drive module codes detected

P0478 Continuous exhaust pressure control valve high imput

P0470 Continuous exhaust pressure sensor

I have owned the truck for two years but it was just certified and put on the road last week. All fluids levels are fine, just curious if the straight pipe may have influenced the exhause back pressure sensor/tube and trown off the sensor. Or if there is a bigger sensor/injection problem on my hands.

Any imput would be appreciated

Thanks: Kyle

Last edited by 99_flatbed; 02-21-2011 at 12:38 PM. Reason: clarity
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-22-2011, 01:53 PM
Powerstroke.org Rookie
 

Join Date: Feb 2011
Location: Caledon Ontario
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had the truck towed to the local ford dealer. The truck was hard to start and idled very rough. No matter how much throttle you give the truck it wont rev up. I'm assuming this has to do with the ecm govorning the engine because of how badly it is running.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors