HIPOP reservoir leaks back - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-07-2011, 10:33 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2011
Location: McPherson
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HIPOP reservoir leaks back

I just had the main oil pump replaced back in Dec of '10 at the dealer, they said it would fix the problem, well it didnt. I was also told that the o-rings on the timing cover and oil pick up tube could be bad, so i pulled the engine and replaced all of those. I now have the engine back in and i am still haveing the same problem. Has anyone else had this problem, and if so how the hell did you correct it!
kdean_f250 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-07-2011, 03:44 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2011
Location: McPherson
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Has no one ever had this happen?
kdean_f250 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome