No boost issue - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-18-2011, 12:18 PM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2010
Posts: 192
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No boost issue

Hi,
I went on a 1300km trip yesterday and made it to my destination in one piece.
About a 1/4 of the way through the trip I did a stop in a snowy lot, got stuck, manually locked the hubs and crawled out. I went in yet another unplowed area, did the same thing only the 4x4 wasn't working, only the rear wheels spun. I could hear the Tcase engaging, but no 4x4. Ended up getting out (thanks Dodge haha) but I noticed that there was a lack of power (stock truck, no tunes etc) after this happened. I turned the radio off and could hear what sounded like a high pitch squeal when I went WOT and had no power in first and it didn't start boosting until at least 2100rpm in second/third. Seemed to have good power after that.
My question is a mix I suppose. Does the 4x4 issue and the boost issue have something in common such as a vacuum leak (ESOTF doesn't work in auto), or is the boost issue just a cracked coupling or something of that nature?
Any other common places I could look? I miss the power, driving on a mountain pass with boost issues sucks.
Truck has a new turbo, new heads, new fuel filter
jaggermouth is offline  
post #2 of 3 Old 09-11-2011, 02:49 PM
Compression Ignition Addict
 
Country Mav's Avatar
 
Join Date: Nov 2007
Location: Evans, Louisiana
Posts: 609
Thanks: 6
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
My truck is doing something very similar... no boost until upper RPMs.... Anybody?

2005 F-250 Lariat FX4 CC SB
Sinister EGR Delete
Diamond Eye 5" Turbo Back Straight
OEM Gaskets and ARP Studs...
SCT X3 (Quick-Tricks tuning)
S&B Intake
Edge CTS
Full Syn 15w-40
High idle mod
PMM Coolant Filter
Rebuilt FICM with Atlas 40

2006 F-350 XL RC/Flat Bed
EGR Delete
SCT SF3 (stays on tow agg)
FARM TRUCK


Diesel spark plugs are the bestest spark plugs....
Country Mav is offline  
post #3 of 3 Old 09-11-2011, 03:04 PM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2010
Posts: 192
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I think mine was a frozen intake filter. was fine ever since
jaggermouth is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome