7.3 loses power, stalls, no restart after 10 minutes of driving - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-12-2011, 02:59 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 loses power, stalls, no restart after 10 minutes of driving

newbie needs help...
95 F250 7.3 Powerstroke, no mods other than exhaust opened up.
No engine light on.
Starts fine in the morning, warmup 15 minutes, drive on highway 10 minutes to work, almost make it, loses power, very rough idle, eventually stalls over the next few minutes, will not restart until 30 minutes approx. Repeat.
Replaced exhaust back pressure tube 2 weeks ago seemed fine after that. Now the same symptoms only worse than before. Did not replace back pressure sensor... but no codes or light this time. Did have engine back pressure code before replacing the exhaust back pressure tube. Any ideas, or things to check??? Thanks.

Last edited by meporter69; 01-13-2011 at 03:01 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-13-2011, 04:10 AM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Found similar problem on another site suggesting IPR is the problem. Will try changing it and post back here.
Reply With Quote Quick reply to this message
  #3  
Old 01-13-2011, 06:28 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,827
Thanks: 1
Thanked 80 Times in 75 Posts
Feedback Score: 3 reviews
Sounds more like a CPS to me.....
Reply With Quote Quick reply to this message
  #4  
Old 01-13-2011, 07:45 AM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Replaced it with new Ford CPS installed a year ago. Cheap to replace... will try it.
Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:12 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors