New 7.3 motor problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-04-2011, 12:04 PM
Powerstroke.org Rookie
 

Join Date: Sep 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New 7.3 motor problems

Hey guys i recently took my truck to a shop to get repaired for no start. Any way what started all this was driving down road check engine light came on and died and could not get no oil pressure. Took to shop and they started to dig in it and found alot of slop in bottom end so he called me and asked me what i wanted to do i said well if the motor is bad rebuild it (truck had 400000 miles on it). So any way 8300.00 dollars later complete motor with turbo minus injectors. Truck runs just as bad as the old motor. Drove truck home from shop about 60 miles away and truck died just like it did when i took it in. Called the shop they towed it back and found some valve or sensor sticking in high pressure pump. When i say bad i mean no power when you start truck if it starts there is no power at all put the pedal down to the floor and it wont move untill it sits there and warms up for a good 30 to 40 min. Then when it finally goes runs like ****. (forgot to mention old injectors was used out of old motor because they were rebuilt ones from a year ago from pensocola diesel) Any help would be greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-04-2011, 07:03 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2010
Location: Conrroe Tx,
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would find another shop. Those pope don't sound to smart.
Reply With Quote Quick reply to this message
  #3  
Old 01-04-2011, 07:04 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2010
Location: Conrroe Tx,
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sorry those people don't sound to smart.
Reply With Quote Quick reply to this message
  #4  
Old 01-06-2011, 07:49 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like you should check the fuel system, Clogged fuel pickup? Fuel pressure?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors