7.3 Stalling and sputtering - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-16-2010, 09:33 AM Thread Starter
Compression Ignition Addict
 
bcoutsfly's Avatar
 
Join Date: Jan 2009
Location: Cary, IL / Fort Worth, Tx
Posts: 312
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3 Stalling and sputtering

I have been searching this problem but the only thing that will come up is CPS, which I replaced about three years ago. Don't know if they just go bad or not.

Here's the deal. Sometimes the truck runs perfect and sometimes it will idle like junk and run like junk. It will die if I'm coming to a stop or making a turn. The SES light only comes on when I start the truck, after about a minute or so the light goes away. Tried hooking a scanner up to it but the OBD2 will not power the scanner.

Any ideas?

2003 7.3PSD Lariat
6" Fabtech
TS 6pos
Straight Piped
DIY Intake
Turbo, Tranny, EGT Gauges.
bcoutsfly is offline  
post #2 of 4 Old 12-18-2010, 08:09 AM Thread Starter
Compression Ignition Addict
 
bcoutsfly's Avatar
 
Join Date: Jan 2009
Location: Cary, IL / Fort Worth, Tx
Posts: 312
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Anyone have an idea?

2003 7.3PSD Lariat
6" Fabtech
TS 6pos
Straight Piped
DIY Intake
Turbo, Tranny, EGT Gauges.
bcoutsfly is offline  
post #3 of 4 Old 12-20-2010, 06:35 PM
Member
 
Jamessims's Avatar
 
Join Date: Jul 2010
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
CPS are cheap takes 5 min to change out and 25 dollars and a 10mm deep socket try it if not try changing out the throttle postion sensor or find a 7.3 shop that specializes in them and have them tell you what is wrong and change it out.... dont go to ford dealer find a 7.3 guro
Jamessims is offline  
post #4 of 4 Old 12-21-2010, 07:35 AM Thread Starter
Compression Ignition Addict
 
bcoutsfly's Avatar
 
Join Date: Jan 2009
Location: Cary, IL / Fort Worth, Tx
Posts: 312
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I figured it out, it ended up being my ICP sensor. Anyone know where to locate one? I hear Ebay's are course thread, I need fine thread.

2003 7.3PSD Lariat
6" Fabtech
TS 6pos
Straight Piped
DIY Intake
Turbo, Tranny, EGT Gauges.
bcoutsfly is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome