7.3 Bad Head Gasket??? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-14-2010, 07:32 PM
Member
 

Join Date: Apr 2006
Location: Wilmington
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
7.3 Bad Head Gasket???

I just bought a modded 2003 7.3. about 4 days later I noticed coolant was blowing out degas bottle. Truck has good power over previous 2001, but coolant leak was a concern. After checking usual suspects and replacing t-stats etc, I've come to conclusion blow by in head gasket. Only losing coolant under boost, like at highway speeds or semi loaded. Check sig for mods. Just wondered what cost I should expect for new head gaskets. That's a job a little above my pay grade unfortunately. Damn I finally got my dream 7.3 set up and this happened. My wife is in her glory. Any thoughts appreciated. The truck ran fine for 4-5 days before problems occurred with coolant leak. I lost heat first, that's what made me lift the hood. All downhill after that. The truck has a 13 month old Jasper engine with 9800 miles (Jasper informed me it had a 12 month warranty....figures)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-14-2010, 07:41 PM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
ugh man im sorry. sounds right to me. take her apart eh?
Reply With Quote Quick reply to this message
  #3  
Old 12-14-2010, 07:43 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2010
Location: DeLand,FL
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
maybe injector cups?is there some diesel in the water?and how much boost is it maxin out at
Reply With Quote Quick reply to this message
  #4  
Old 12-14-2010, 07:51 PM
Member
 

Join Date: Apr 2006
Location: Wilmington
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
never seen over 25 psi ...yet. No fuel or oil in coolant that I've found. One off note question, this truck has a FASS system and I stay at a constant 20 psi of fuel pressure, is that normal sounding. My '01 didn't have fuel pressure gauge or fass. Noticed some guys pushing 40-60 psi. Just curious
Reply With Quote Quick reply to this message
  #5  
Old 01-28-2011, 12:24 PM
Member
 

Join Date: Apr 2006
Location: Wilmington
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Got her back today.....time will tell
Reply With Quote Quick reply to this message
  #6  
Old 01-28-2011, 04:08 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,047
Thanks: 29
Thanked 38 Times in 36 Posts
Feedback Score: 0 reviews
20 psi of fuel pressure is WAY low... Bad for injectors low...

Was it a blown head gasket? Thats very uncommon at only 25# boost...
Reply With Quote Quick reply to this message
  #7  
Old 01-28-2011, 04:19 PM
Member
 

Join Date: Apr 2006
Location: Wilmington
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
That fuel pressure comes from the fass pump.found dirty pressure gauge on regulated fuel return...looks like 50 Psi or so. Also saw 38+ psi on boost. Apparently bad head bolt on #2 cylinder. .
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:46 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors