Parts are in - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-05-2006, 03:41 PM
Compression Ignition Addict
 

Join Date: Nov 2005
Location: Big Cypress Indian Reservation
Posts: 2,756
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Parts are in

All right all my parts came in and tommarrow I will try to get my truck running. I know where everything is except the exhaust back pressure sensor(a little help here Marc). If this doesnt fix it I gonna put a match to it. Just kidding. I love my truck too much to do that. Ya'll keep yall's finger crossed for hope pray whatever you think will work for me.
TJ
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-05-2006, 04:14 PM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,845
Thanks: 7
Thanked 34 Times in 24 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
We're all with ya LilRed and you know Marc he rocks - I wish I could be there to lend a hand buddy.
Reply With Quote Quick reply to this message
  #3  
Old 05-05-2006, 04:55 PM
Compression Ignition Addict
 

Join Date: Nov 2005
Location: Florida
Posts: 362
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by lilredpowestroke
All right all my parts came in and tommarrow I will try to get my truck running. I know where everything is except the exhaust back pressure sensor(a little help here Marc). If this doesnt fix it I gonna put a match to it. Just kidding. I love my truck too much to do that. Ya'll keep yall's finger crossed for hope pray whatever you think will work for me.
TJ
I can't even see the EBP valve let alone the sensor.
Reply With Quote Quick reply to this message
  #4  
Old 05-05-2006, 05:12 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
the sensor on yours should be in the H2O pump area.......there will be a metal tube coming off the right exhaust maniford right at the very front of the manifold....visable from below the bumper.....it goes up and dead ends at the sensor......Marc
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:51 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors