99 high idle question? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-25-2010, 08:49 AM
Member
 

Join Date: Nov 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99 high idle question?

just put a 4'' turbo back kit on and i noticed that whenever it goes in high idle it will the rpms stay the same but the exhaust goes from sounded like a 747 to just soundin like a normal powerstroke during high idle. goes back and forth every couple of seconds.. would that mean that the waste gate is closing..my old powerstroke would just stay the whistling mode. didnt know if i just need to upgrade the wastegate or what? any info would help.. thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-25-2010, 09:13 AM
The Tamed Racing Driver
 

Join Date: Oct 2009
Location: Home-Taneytown, Maryland; School- Lima, Ohio
Posts: 3,229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Its probably your EBPV (Exhaust backpresesure valve). It blocks off your exhaust to help warm the truck up faster.
Reply With Quote Quick reply to this message
  #3  
Old 11-25-2010, 11:55 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: Cookeville, TN
Posts: 450
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Yeah sounds like your EBPV doing work, should be fine.

Could need a cleaning too, check out this thread..

Winter Operation, Hard Starting, Hissing Sound Etc...

Last edited by Cjcross22; 11-25-2010 at 12:01 PM.
Reply With Quote Quick reply to this message
  #4  
Old 11-27-2010, 04:21 PM
Member
 

Join Date: Nov 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok cool.. my only thing is i have never heard a 7.3 do what mine does. goes lope then whistle lope then whistle wont stay at and constant whistle during high idle. then driving down the road it will go in a whistle mode at low speeds and low rpms until it warms up..ill pull the sensor off and clean it and see if it stops.. sensor is in the front top of the motor correct?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors