down on power when under a load or wot - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 11-05-2010, 06:57 PM Thread Starter
Powerstroke.org Rookie
 
20007.3 supercab's Avatar
 
Join Date: Dec 2007
Location: desoto mo
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
down on power when under a load or wot

As the title says my truck is down on power only when under a load, 3/4 throttle or wide open throttle. I just replaced the cam sensor, ipr valve and the icp sensor checks out good, fuel filter is brand new, i use 15w40 motorcraft oil. Truck idles fine,starts up great, maintains highway speed fine. I dont think it would be the hpop because thats mechanical and would probably cause running issues all the time. My fuel pump is very noisy when I turn the key to let the glows warm up. Could the pump be weak and not able to keep up under a heavy load demand?Needless to say im out of ideas and dont want to replace parts that arent bad and expensive, starting to ? the reliability of my 7.3 so help is appreciated greatly. Truck has 161,000 miles also and I did notice my hpop has a remanufactured sticker on it so it dosent have as many miles as the truck does.

2000 white supercab longbed, 4x4, 7.3 powerstroke, 4r100, predator tuner, straight pipe, k&n, fpr shim , foil delete, zoodad mod, boost fooler, wastegate delete, 3.73s, iah delete, exaust backpressue valve delete
20007.3 supercab is offline  
post #2 of 6 Old 11-06-2010, 07:07 AM Thread Starter
Powerstroke.org Rookie
 
20007.3 supercab's Avatar
 
Join Date: Dec 2007
Location: desoto mo
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump, I know someone has some good imput!

2000 white supercab longbed, 4x4, 7.3 powerstroke, 4r100, predator tuner, straight pipe, k&n, fpr shim , foil delete, zoodad mod, boost fooler, wastegate delete, 3.73s, iah delete, exaust backpressue valve delete
20007.3 supercab is offline  
post #3 of 6 Old 11-06-2010, 05:22 PM Thread Starter
Powerstroke.org Rookie
 
20007.3 supercab's Avatar
 
Join Date: Dec 2007
Location: desoto mo
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I replaced the fuel pump and it seems alittle better, Pressure is more steady, but still down on power, seems to be intermittent with the symptions now and if you run the truck long enough really hard u can start to hear the injectors firing like they are starving for fuel.

2000 white supercab longbed, 4x4, 7.3 powerstroke, 4r100, predator tuner, straight pipe, k&n, fpr shim , foil delete, zoodad mod, boost fooler, wastegate delete, 3.73s, iah delete, exaust backpressue valve delete
20007.3 supercab is offline  
post #4 of 6 Old 11-10-2010, 06:55 PM
Powerstroke.org Rookie
 
Join Date: Dec 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 20007.3 supercab View Post
So I replaced the fuel pump and it seems alittle better, Pressure is more steady, but still down on power, seems to be intermittent with the symptions now and if you run the truck long enough really hard u can start to hear the injectors firing like they are starving for fuel.
I had a similar problem awhile back. There are two filter screens in the fuel sending unit in the tank. Mine were almost plugged completely off with gunk. Bad thing is gotta drop the fuel tank but it fixed the problem.
duke 7493 is offline  
post #5 of 6 Old 11-12-2010, 08:28 PM
Serving Our Country!
 
JSchuricht's Avatar
 
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,967
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 25 Times in 24 Posts
Feedback Score: 2 reviews
Check your ICP when your loosing power. Sounds like the HPOP could be weak.

JSchuricht is offline  
post #6 of 6 Old 11-13-2010, 06:33 AM
Compression Ignition Addict
 
atvrider93's Avatar
 
Join Date: May 2010
Location: Raleigh, NC
Posts: 3,835
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 12
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
check fuel pressure and your hpop
atvrider93 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome