ICP pressure - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-25-2010, 09:47 AM
Compression Ignition Addict
 

Join Date: Apr 2009
Posts: 205
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ICP pressure

I installed my CTS Insight a couple days ago and noticed that my ICP pressure at idle is only 350-380 psi and the IPR is at 10-11% duty cycle, this seems low to me. I found oil in the connector of the ICP sensor so i replaced it with a new sensor from Ford. My ICP pressure remains the same. I also only see 2000psi max at WOT with 38% IPR. When i unplug the sensor the idle gets a little smoother and my CTS shows 500psi at idle. It has a fresh oil change and no visible leaks. The truck is in my sig and has 155,000 miles. Are these normal conditions? Oh, i also have 400psi at 15% IPR on initial start up in the morning but after about 10 minutes of driving it goes down to the 300psi. Oil level is also correct. Thanks for the replies.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-25-2010, 06:18 PM
Powerstroke.org Rookie
 

Join Date: Sep 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does the truck have an running issues (hard to start, hesitation, low power)? When checking the ICP pressure you have to have a hard load on the engine to reach max pressure. Try putting it in gear, set the park brake, hold your foot on the brake pedal and start slowly accelerating. You should see a higher pressure that way.
Reply With Quote Quick reply to this message
  #3  
Old 09-25-2010, 09:24 PM
Compression Ignition Addict
 

Join Date: Apr 2009
Posts: 205
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I tried that and i only saw a max of 2000psi at 38% IPR again. Are these normal numbers from an un-tuned truck?
Reply With Quote Quick reply to this message
  #4  
Old 09-25-2010, 09:28 PM
Cynic
 

Join Date: Jun 2007
Location: Fort Worth, Texas
Posts: 11,194
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
When you pull the ICP sensor connector, it should default around 800-900psi. Sounds like a bad ipr or hpop is dying.
Reply With Quote Quick reply to this message
  #5  
Old 09-25-2010, 09:40 PM
Compression Ignition Addict
 

Join Date: Apr 2009
Posts: 205
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah when i pull the plug it goes right to 500psi and the idle smooths out. So i guess it's IPR/HPOP time.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:35 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors