Pinging under load? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-23-2010, 11:47 AM Thread Starter
Member
 
Join Date: Nov 2008
Location: Pickering, Ontario, Canada
Posts: 86
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Pinging under load?

hey guys just recently my truck has developed a weird condition under any type of heavy load/boost. Seems like if i pass the half throttle mark it pings and makes knocking noises. Sounds like its coming from the left side of the engine compartment. Do diesels ping like gas motors? i mean i own 2 turbo gas cars (both run low 11s) and the noise that my powerstroke makes sounds like a gasser with 87 octane and 20psi of boost lol

Danny

2000 E-350 Van (5k resistor)(custom Intake)
440k and runs like its new
Turbolag87 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-24-2010, 05:49 AM Thread Starter
Member
 
Join Date: Nov 2008
Location: Pickering, Ontario, Canada
Posts: 86
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump ttt,,,

2000 E-350 Van (5k resistor)(custom Intake)
440k and runs like its new
Turbolag87 is offline  
post #3 of 4 Old 09-24-2010, 05:28 PM
Powerstroke.org Rookie
 
Join Date: Sep 2010
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Few things come to mind, bad fuel (diesels use cetane like gas has octane), low fuel pressure on the left bank or total low pressure (bad pump, clogged filter, bad fuel pressure regulator), and the worst and I hope it is not is the turbo bearings could be coming out.
bbird121484 is offline  
post #4 of 4 Old 09-26-2010, 08:54 AM Thread Starter
Member
 
Join Date: Nov 2008
Location: Pickering, Ontario, Canada
Posts: 86
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'll try using a different type of brand of fuel. I guess i can try replacing the fuel filter. I doubt its the bearings but ill check for shaft play

2000 E-350 Van (5k resistor)(custom Intake)
440k and runs like its new
Turbolag87 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome