Inj Buzz test P1277 - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-20-2010, 08:17 AM Thread Starter
Join Date: Feb 2010
Location: Apache Oklahoma
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Inj Buzz test P1277

My 02 7.3 is running rough and missing with the engin light on. ran the injector buzz test and it came up with P1277. I checked the harness connection on the outside of the valve cover and it looked fine but could it still be burnt up on the inside or is the #7 injector bad. Sometimes when running down the road the light goes off and runs fine untill i put my foot into it. any help would be appreciated.

95 Powerstroke 5 speed regular cab 4x4 W/bale spike bed, strait pipe, front bumper.

06 Powerstroke, 4 door, short bed, auto, 4x4, lariat, strait pipe, Banks six gun.

99 f-350 W/02 engine 6 speed 4D, 4x4, bale spike bed, Alcoa aluminum wheels, 4 inch TB strait pipe, BDP stage 2 injectors, ts 6 position chip, diy intake, autometer boost/pyro, boost fooler
bore355 is offline  
Sponsored Links
post #2 of 3 Old 09-22-2010, 06:07 PM Rookie
Join Date: Sep 2010
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just got done with one just like it. The light comes on under load to tell you there is a injector problem. You may have already been told that the 7.3 is notorious for the valve cover gaskets losing connection through them. The high heat and then cooling causes a lot of expanding and contracting so any gap causes an open. And it can't be seen by any means. Unless you have just replaced the gaskets, i would try and change those first. Then look at the injectors next. If you need the gaskets, I found a set at NAPA cheaper than even International could sell them.
bbird121484 is offline  
post #3 of 3 Old 09-22-2010, 06:12 PM

SCUFFY828's Avatar
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,279
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
02 models dont burn the harness like the obs trucks did , remove the passenger side valve cover and what you will find is that its loose under there

SCUFFY828 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome