7.3 wont run right - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-17-2010, 04:03 PM Thread Starter
Powerstroke.org Rookie
Join Date: Apr 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 wont run right

Hi all
I have a 2001 f550 with 27k miles on it .When it starts up some times
it lops really bad it my stall but if you hit the throttle right away it will straighten right out. It then started to blowing white smoke really bad and missing with no power After running at 65 mph for 15 miles . I changed the cps and the fuel filter and the o rings in the fuel bowl the lope is still their some times But the truck will go longer before it acts up and if you let off the pedel sometimes it will stop acting up and run fine and other times you have to shut it off for 2 minutes then it is fine again for awhile.While it is mising bad i have opened up the fuel drain and fuel pores out and engine keeps runing but missing bad and blowing white smoke shut it off and wait and start it up its fine. thier are no codes in the scanner
Any ideas

Last edited by sink410; 09-19-2010 at 04:08 PM.
sink410 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome