loss of power - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-10-2010, 11:18 AM Thread Starter
Compression Ignition Addict
Join Date: Feb 2010
Posts: 185
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
loss of power

Ive got a 2000 f250 cc 4x4 that I got about 2 months ago and it has 165k on it. It was all stock when I got it and it ran great and I didnt have any trouble, shortly after I got it I installed 4" straights on it and that made a noticeable differance in power but not too much. At that time it ran fine but over the past few weeks it has seemed to have lost a noticeable amount of power, especially on low end, and the mpg has seemed to drop noticeably also. The truck sounds fine and still runs smoothly, but when youre taking off it seems very sluggish. I have also installed a greasecar kit and run it on vegetable oil, but it started this before I installed that, and it runs the same way on oil or diesel. Right now I have the ebp sensor disconnected because I need to clean the tube which was completely clogged up with soot. Does anyone have any ideas what this could be?
Thanks for any help
mpiller is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome