00, 7.3 Blowing Underhood PCM Fuse , Please Help - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-06-2010, 04:55 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
00, 7.3 Blowing Underhood PCM Fuse , Please Help

I have a 2000 Ford F-350, with 7.3 was an auto, but swapped to 6spd when I got it, which we have put 30,xxx miles on it since swap-no issues, 4x4.
Truck currently has 240,xxx miles, the other day it just randomly died, would crank but not restart found 20amp Maxi Fuse under the hood had blown, it was either #25 or 24 cant remember, but its one that controls Pcm, i think other is powerwindows or something, I have read thru multiple threads about the fuel heater causing issues like this but that also appears to be fuse #30 under the dash? which mine is fine.
truck will restart and run for couple miles when the fuse is replaced but the pops it again, I also did unplug the fuel heater and still does same thing.
I have ordered a wiring diagram, detailed for my truck so I can start tracing where all the wires go from that fuse, but does anyone have any ideas??
All help would be appreciated.
bronco2guy is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome