What now????? - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-03-2010, 07:46 PM Thread Starter
Compression Ignition Addict
Join Date: Jul 2009
Location: Riverside, CA
Posts: 276
Thanks: 6
Thanked 4 Times in 4 Posts
Mentioned: 1 Post(s)
Quoted: 32 Post(s)
Feedback Score: 0 reviews
What now?????

I had a problem a couple months with my truck acting up where intermittently lose power when going down the road, when it did the check engine,water in fuel and wait to start lights would come on. when the lights went off (1-2 sec) everything would be fine, sometimes it does it back to back sometimes it will do it once.

Anyways took it in when the truck wouldn't even start anymore. Turns out IDM went bad and caused the truck not to start and the ICP was causing the intermittent power loss.

Tonight (2 months later) the intermittent power loss is back! Is it possible the ICP went/is going bad??? What would be causing this???

2014 F250 4x4 CCSB Platinum
Dieselsite water/fuel filter, Stingray 40" LED with Randy Ellis mounts, High Idle mod, Airbags, Marathon Seat Covers, LED lights.

2012 Eclipse Stellar 27DBLG

Sting is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome