Fuel smell, service engine light on - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-27-2010, 08:42 AM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel smell, service engine light on

Hi, first time poster with a problem.

Vehicle: 2002 Excursion, 4x4, 7.3L. 117,000 miles.

About 4 months ago, I started noticing a small diesel leak in the center of the engine, but couldn't trace the origin and wasn't too concerned about it. Thought it might have been from the fuel filter gasket leaking and was due to change it. Engine started easily and ran fine with no significant fuel odor while running.

About 3 months ago, I replaced the fuel filter with a Napa (Wix) and didn't notice any leak at first, but started noticing a small leak again after about a week.

About a month ago, it started fine and went about a mile and started running rough stalled out. I suspected water in the fuel and drained the fuel filter housing. Engine ran fine. This happened a few times, always in the morning, and when I let out some fuel in the housing, it ran fine afterwards.

A couple of days ago, I noticed that the transmission was slow to shift to the higher gears. I had to left off the gas a little for it to shift. ATF level is fine.

Yesterday, the service engine light (the silhouette of an engine) came on. Engine runs okay, not as smooth as it was.

Any ideas? Water in tank? ICP? When I let out fuel out of fuel filter housing, I don't notice any water. Is the transmission coincidental or could it be related to the diesel?

FWIW, I was a wrench 30 years ago as a 20yo but never had much experience with diesels.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-27-2010, 09:25 AM
<-Day Of Fail now SOLD

 

Join Date: May 2008
Location: Japan
Posts: 3,393
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where you located maybe one of the local boys can stop by and help out.

Best of luck, heres a bump
Reply With Quote Quick reply to this message
  #3  
Old 07-30-2010, 05:27 PM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fixed it. Done. Saved a ton of $$$ by not having to take it to the dealer as the wife wanted to.
Reply With Quote Quick reply to this message
  #4  
Old 07-31-2010, 09:05 AM
Member
 

Join Date: Jul 2010
Location: Federal Way, WA
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
WELL?

hey guys,
Are you going to tell us what it was?
Reply With Quote Quick reply to this message
  #5  
Old 07-31-2010, 09:53 AM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was the ICP sensor and the pigtail harness. Replaced both for $233. If you have any specific questions, pm me.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors