HELP!.. I Assume this must be bad. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 07-06-2010, 07:36 PM Thread Starter
1faststang's Avatar
Join Date: Jul 2009
Location: Central Alberta
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP!.. I Assume this must be bad.

My 2000 7.3 was running great , But had trouble starting in the morning if it wasnt above 45f, would start later in the day when it was warm out. With 435000k I assumed it was time for glowplugs and relay. Pulled off the Drivers side Valve cover and pulled the glow plugs and tested each of them on the bench with a 12v battery and a digital thermometer. They went 600 degrees and white hot in 6-8 sec. Thought great!,Put them all back in and tested the relay and it was shot, Grabbed a new one from Ford Dealer And Put it all back together. It fired right up,, but ran rough like its missing or something, drove up the block and drove like crap. Came back and searched the forums and narrowed it to the Under Valve Cover Harness plug, Took VC off again to inspect and found the Outer Glow plug harness wires were crumbled. SEE PIC.

I assume this is my problem?? Is it easy to replace this or is it the whole engine harness? Should I tow it to the dealer(ripoff) and let them fix it?

I need to get on this , as my family is expecting to go camping in 10 days with the holiday trailer.

Any help is appreciated.

2000 F250 Lariat 4X4 Extended Cab Shortbox...433,000 kms

Rough Country 5" lift
MBRP 4" Turbo Back Exhaust
Wicked Wheel
S&B Intake
Foil Delete
TW 6-Pos Chip
Autometer Phantom Gauges
35" Pro-Comps
2007 Grill Conversion
Westin Bull Bar
Stampede Ruffridrz Flares
Big Willy Box Rails
1faststang is offline  
Sponsored Links
post #2 of 2 Old 07-06-2010, 08:57 PM Fanatic
Join Date: Jun 2009
Posts: 143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Alliant power. the Ford IH engine guys, sell pigtails with connectors, to replace the piece you are showing. I don't have the part number, just look it up. they are reasonably cheap. You don't want to know the cost of a harness, if you can get one.

On edit, just saw that you are in central alberta. GCL diesel sells the pigtails I am talking about, and if I remember right, they keep them in stock.
Highwaywrench is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome