Gray/White Smoke - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-03-2010, 08:48 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Posts: 666
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Gray/White Smoke

My truck is blowing some white/gray smoke at intermitent times when it should be all black. I changed my ICP sensor about 2 months ago because it had oil in it and the truck would blow light gray/white smoke at times when it should have been black. I put new sensor and it blowed black smoke all the time until a couple weeks ago and its doing the same thing blowing white/gray smoke at times. There is no oil in sensor but could it be bad again already? What the heck would cause it to go bad so soon? The connector seems fine to so I didnt replace. The truck runs strong and has tons of power but the smoke just isnt the correct color. It does idle a little ruff when first started but then its fine after a few seconds. What else could cause the white/gray smoke but the truck still run good. I do not have any check engine light on.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-03-2010, 09:05 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Posts: 666
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I should mention it does this on all chip settings on my ts chip except if I turn the chip to stock there is no smoke of any color at all like it should be.
Reply With Quote Quick reply to this message
  #3  
Old 07-03-2010, 09:39 PM
Powerstroke.org Rookie
 

Join Date: Jan 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
im here that every where i read sames alot of the chips this year are messing up wonder why glad mines stock for now
Reply With Quote Quick reply to this message
  #4  
Old 07-05-2010, 07:59 AM
Compression Ignition Addict
 

Join Date: Jun 2008
Posts: 666
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Bump... What can cause the ICP to go bad already? Is there any good way to test the connector to see if it is shorting out?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors