New injector cups and still doesnt run - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-03-2010, 11:14 AM
Member
 

Join Date: Jul 2008
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New injector cups and still doesnt run

Well after countless people telling me the injector cups where causing my over fueling problem i went ahead and put all 8 injector cups in. It still does the same thing. The truck will start and run for 2-3 mins. fairly smooth with just a light haze out the exhaust which i see as normal after all the exhaust is still pretty filled with fuel and oil from before so when it does run im sure it'll smoke a little for a while. But, it runs for 2-3 mins then starts knocking and smoking like crazy. Its a fuel knock and the smoke is unburnt fuel for sure. I just had rosewood rebuild this set of injectors i havent but a mile on them yet. I'm lost the truck did the same thing to me when i was driving down the highway with the cruise set and a started to hear a slight knock and started running rough. i saw smoke out of the stack and pulled over. the truck hydro locked and i though it was the orginal injectors taking a dump after 240,000 miles. The truck runs good for 2-3 mins then, when the temp guage starts coming up it severly over fuels. After changing pcm, idm, injector cups, injectors, and head gaskets im lost Any help what do you suggest i do next.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-03-2010, 01:14 PM
Compression Ignition Addict
 

Join Date: Dec 2009
Location: Montgomery, TX
Posts: 539
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have no evidence to support this ever happening, but is there any chance a fuel rail could get a crack or other defect in it that wouldn't completely seal it from the cylinder? What are the odds that you would get a bad injector, or an injector with a cracked tip? Very weird.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors