Brain Teaser - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-15-2010, 01:44 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Brain Teaser

Ok 01 f550 7.3 standard trans 175,570
Parking brake light on dash doesn't come on most of the time I put the brake on. Truck CAN start without pressing clutch pedal. The Auxiliary Idle Control Module PTO, RPM idle up doesn't work it powers up shows idle that's it.
I know parking brake has to be set for the Auxiliary Idle Control Module to work but the brake light used to come on but still didn't work. The Auxiliary Idle Control Module used to work about 6 months ago. The wire on the parking brake pedal is pluged in. ?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-15-2010, 01:49 PM
Serving Our Country!
 

Join Date: Dec 2007
Location: Kodiak, AK
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had this happen on my 2000 F-250, ended up replacing the Parking Brake switch, took me 5 minutes, only one screw and one wire. The part cost me 15ish dollars from the local Ford dealer. The switch is located by the parking brake.
Reply With Quote Quick reply to this message
  #3  
Old 03-15-2010, 05:15 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok checked parking brake switch is ok, grounded out wire to parking brake and parking brake light still dont come on.
Second i looked at the clutch switch and it looked loose so i took it off and slided the switch to the position which would be as if the clutch would be pressed and started the truck without the pressing the pedal and it started then i switched it to as if i released the pedal and tried to run my Auxiliary Idle Control Module and it works now PTO RPM happy now. i know it is not suppose to work without the parking brake on so i was thinking maybe the light bulb for the parking brake is out.
Reply With Quote Quick reply to this message
  #4  
Old 03-15-2010, 06:59 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok got new switch for clutch my old one was missing a clip, put new one in Auxiliary Idle Control Module works now
also was driving down the road and pressed the parking brake just a little to ground out switch and the chimmer sound comes on letting me know the brakes are on But no parking light, guess the dash brake light bulb maybe out
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors