Runs rough and no power - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-10-2010, 07:25 AM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Runs rough and no power

Need some help!! Ive got a 2000 Excursion 7.3 125.000 miles on it. Has been running really good. Tried to start it this yesterday morning wont start, hits on about 2 cylenders. Replaced fuel filter droped tank cleaned the 2 filters in the tank mixer, they were pluged with a black tar like stuff same as filter. Fuel tank is clean. Tried to start it but same thing. Switched out fuel pumps with my 01 550. 550 still runs good. Finily got the Excursion to start, runs really rough and has no power, wont hardly un-track it self.
Thanks
Update: It is only hitting on the pasenger side of the engine, nothing on the other side

Last edited by mcguiver56; 03-10-2010 at 08:48 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-10-2010, 10:37 AM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Found the problem!! The conector on the inside of the valve cover gasket was unpluged.
Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors