No oil pressure under 1200 RPM - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-29-2006, 09:28 AM
Powerstroke.org Rookie
 

Join Date: Mar 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No oil pressure under 1200 RPM

I have a 1999 ford f-550 7.3 under 1200 rpm the oil light comes on. I changed the low pressure oil pump and front cover and seal . Same problem.. I checked the check valve inside the oil filter housing and that is fine also. The engine runes ruff real ruff. Wondering if anyone has a clue or has a similar problem. Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-29-2006, 11:03 AM
Premium Member
 

Join Date: Jan 2006
Location: florida
Posts: 1,893
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oil pressure switch?

may be a stupid question, did you try the oil pressure switch?
i had changed mine on my 92 250 after similar problems. engine did not run rough though..

link to switches

Last edited by Brian; 03-29-2006 at 11:10 AM.
Reply With Quote Quick reply to this message
  #3  
Old 03-29-2006, 11:04 AM
Powerstroke.org Rookie
 

Join Date: Mar 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I should have listed that , It was the first thing I changed.
Reply With Quote Quick reply to this message
  #4  
Old 03-29-2006, 11:10 AM
Premium Member
 

Join Date: Jan 2006
Location: florida
Posts: 1,893
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dunno

hang tight, you will get some good educated guesses before to long.
Reply With Quote Quick reply to this message
  #5  
Old 03-29-2006, 12:44 PM
Compression Ignition Addict
 

Join Date: Mar 2006
Location: Australia
Posts: 1,084
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How many miles on the engine? Is it just real tired? Low oil pressure can be worn rod and main bearings, and "runs real rough" can be low compression... Probably a bit basic, but how many miles on her??? She have much blow by? How about blue smoke? If yes to this, you have a answer, not a good one.... but...

Best of Luck from da Ranger in Oz....
Reply With Quote Quick reply to this message
  #6  
Old 03-29-2006, 03:54 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by lilb93
I have a 1999 ford f-550 7.3 under 1200 rpm the oil light comes on. I changed the low pressure oil pump and front cover and seal . Same problem.. I checked the check valve inside the oil filter housing and that is fine also. The engine runes ruff real ruff. Wondering if anyone has a clue or has a similar problem. Thanks
sounds to me like you have a bunch of blowby somewhere that the low pressure pump is unable to overcome at low RPM's.......how many miles??? and do you know the full mainanence history??? has there been any evidence of dusting.......Marc
Reply With Quote Quick reply to this message
  #7  
Old 03-30-2006, 02:56 AM
Powerstroke.org Rookie
 

Join Date: Mar 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
There is NO blowbye at all. There is about 90,000 miles on it. Blows no smoke at all. I am going to pull the engine this weekend.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors